Specific examples of users who have encountered issues described on this site.

Entries listed with "UNCONFIRMED" mean there are no symptoms besides particles in the fuel filter. Entries without "UNCONFIRMED" mean actual damage and usually an inoperable vehicle.

If you've suffered from a HPFP failure, please make sure you report the problem with NHTSA at this page. Without customer reports of the problem, VW is free to ignore the issue.

#1 2009 VW Jetta SportWagen TDI / house-1221 / GA

April 2, 2010

This 2009 JSW was purchased in July 2009. It had under 8,000 miles before needing repair. User is from Atlanta, GA Symptoms Flashing glow plugs indicator light comes on and then the check engine. The engine starting reducing in power I was told the fuel pump was "shredded" - they found ... Read More »

#10 2009 VW Jetta TDI / spjetta09 / WI

April 2, 2010

This 2009 Jetta had 21,500 miles before metal particles were found in the fuel system. User is from Stevens Point, WI. Symptoms My car had an issue starting last december and the dealer said i had contaminated fuel and the fuel filter was hydrolocked User's fuel habits Standard ULSD. No fuel add... Read More »

#11 2009 VW Jetta TDI / maverick395 / TX

April 2, 2010

This 2009 Jetta had 24,000 miles before metal particles were found in the fuel system. After being repaired, metal particles were once again found at 34,000 miles. User is from Texas. Symptoms all I can say is that I hope noone else has the problems with their VW Jetta TDI that I have. (2) count t... Read More »

#12 2009 VW Jetta TDI / jessesrq / FL

April 2, 2010

This 2009 Jetta had two fuel system failures. One under 36,000 miles, and the second one over 36,000 miles. User is from Sarasota, FL. Symptoms Last January after having the car for about 3 months, the fuel pump failed. The unit actually came apart and sent fragments of metal through the tank, fue... Read More »

#13 2009 VW Jetta TDI / dweisel / WV

April 2, 2010

This 2009 Jetta with a build date of 10/08 had 11,173 miles before vehicle required repairs. User is from Wheeling, West Virginia Symptoms Blinking glow plug light and lack of power under load.Then the glow plug light started to blink and there was a chime. I then tried the cruise control............ Read More »

#14 2009 VW Jetta SportWagen TDI / knowledge / FL

April 2, 2010

This 2009 JSW had 34,000 miles before needing repair. User is from Ft. Lauderdale, FL Symptoms glow plug light, sudden loss of power, CEL rust in fuel canister and some deposits in the fuel tank User's fuel habits Standard ULSD. No fuel additives. Mostly Chevron stations. VW response VW... Read More »

#15 2009 VW Jetta (Loyal Edition) / subsonic44 / ME

April 2, 2010

This 2009 Jetta has the distinction of having an owner who made notes on every issue and response he received from VW. I'm not talking about a few paragraphs, but dozens of pages worth of details. Build date is 06/08, purchase date was 08/08. User is from North Berwick, ME Symptoms Loss of power... Read More »

#16 2009 VW Jetta TDI - UNCONFIRMED / JettaTDI09 / TX

April 2, 2010

This 2009 Jetta was delivered on April 2009. Power loss expirenced at 20,700 miles. User is from McKinney, TX Symptoms Random power loss. Drove maybe 10-20 feet and car lost all power. Current status Unknown. User last posted about taking vehicle to the dealership. Issue might be a DSG issue... Read More »

#17 2010 VW Jetta TDI - UNCONFIRMED / Steve Di. / MA

April 2, 2010

This 2010 Jetta has unknown miles on it. User is from Reading, MA. Symptoms Engine quit running and refuse to start. The glow plug symbol flashes and a message appears that reads: "Service Engine Immediately". VW response Vehicle is currently at dealer.... Read More »

#18 2009 VW Jetta TDI / Haz-matt / OR

April 2, 2010

This 2009 Jetta had 28,000 miles at failure. Build date is Feb 2009. User is from Wolf Creek, OR. Symptoms lost power and he barely made it off the freeway The car starts throwing random high/low fuel pressure codes from time to time but since there still seems to be some proble... Read More »

#19 2009 VW Jetta SportWagen TDI / tallymom / FL

April 19, 2010

This 2009 JSW has 21,000 miles before failure. User is from Tallahassee, FL Symptoms Driving last Monday, Engine Malfunction light came on and then went off. Glow plug light continued to blink. Stopped (at baseball field, probably 100 yds after lights went on)Left for evening, no light, very faint... Read More »

#2 2009 VW Jetta TDI / 2009TDINEWBIE / AZ

April 2, 2010

This 2009 JSW was purchased in 2008. It had 18,000 miles before needing repair. User is from AZ. Symptoms Dealer said a fuel sensor failed causing the contamination and replaced everything from the fuel tank on up. User's fuel habits Chevron fuel. Standard ULSD. No fuel additives. VW response... Read More »

#20 2009 VW Jetta TDI Loyalty Edition / Sharpie / MS

April 27, 2010

This 2009 Jetta (Loyalty Edition) had 27,400 miles on it and was purchased June '09. User is from Mississippi Symptoms Yesterday around 2:45 CST my wife called and said that her 2009 Jetta TDI had the glow plug light was flashing, the engine symbol was on and the MFD said engine fault... Read More »

#21 2010 VW Jetta TDI / ferland25 / FL

May 2, 2010

This 2010 Jetta had 13,500 miles before metal particles were found in the fuel filter. User is located in Mims, FL Symptoms Had one oil change and am only at ~14000 with my 2010 Jetta. My car stopped running and the dealer said that I had sand in my fuel filter. They blamed it on bad fuel and want... Read More »

#22 2009 VW Jetta SportWagen TDI / jshoutex / TX

May 2, 2010

This 2009 JSW had 17,000 miles before needing repair. User is from Houston, TX Symptoms MIL (check engine) light came on but noticed no loss of power or function. Took car to dealer. They told me they found metal shavings in the tank, bad fuel with water present, and corrosion around the fuel fi... Read More »

#23 2009 VW Jetta SportWagen TDI - UNCONFIRMED / 02VFR / OH

May 2, 2010

This 2009 JSW has a build date of 07/08. Car delivered 09/08. The dealer found rust diesel in my fuel filter canister during the 20,000 mile service. User is from Newark, OH Symptoms When changing the fuel filter the tech reported the fuel in the filter housing was brown, and I have a sample of ... Read More »

#24 2009 VW Jetta TDI / rick chip / OH

May 2, 2010

This 2009 Jetta quit running 13,000 miles (one year) after purchase on Aug 2008. User is from OH. Symptoms There were no symptoms other then low mileage (36 mpg). We were coming home from diner when it went into limp mode. That was it, off to the dealer. VW told us, through the dealer, they suspec... Read More »

#25 2010 VW Golf TDI / NipomoTDI / CA

May 30, 2010

This 2010 Golf had 3,100 miles before needing repair. User is from CA. Symptoms I drove about 500 feet when all of the sudden a really ugly noise started happening from the engine sounding like an empty spray paint can rattling around in a empty plastic trash can. Put it in neutral, opene... Read More »

#26 2010 Golf TDI / jammicpai / MA

June 1, 2010

This 2010 Golf had less than 5,000 miles / 4 months of ownership before needing repair. It is a DSG with a build date of Nov 09. User is from MA. Symptoms humming sound from the engine, flashing glow plug light, and reduced power. User's fuel habits Standard ULSD. VW respo... Read More »

#27 2009 Jetta TDI / Chadmag / FL

June 4, 2010

This 2009 Jetta had 37,500 miles miles before failing to function. User is from Jupiter FL. Symptoms Driving home from work on the Florida Turnpike and the engine shuts down. MFD says engine fault and maintenance required. Tuesday when they had a chance to finally look at the car I was to... Read More »

#28 2010 Jetta TDI / stylinmama / Canada

June 4, 2010

This 2010 Jetta had less than 9,300 miles before failing to function. User is from Canada. Symptoms about a week ago I'm driving along and suddenly nothing. My car just stops working... COMPLETELY. I have only 15000km's on this car. User's fuel habits Standard ULSD. ... Read More »

#29 2010 Jetta TDI / swb1509 / NY

June 4, 2010

This 2010 Jetta had less than 6,200 miles before failing to function. User is from NY. Symptoms Just started my car after work and while pulling out of the parking lot into traffic it just violently stalled. Would not restart. What I mean by violently is that it stalled as I was pulli... Read More »

#3 2009 VW Jetta SportWagen TDI - UNCONFIRMED / Rather Be Biking / NY

April 2, 2010

This 2009 JSW had 14,500 miles before metal particles were found in the fuel filter. User is located in Buffalo, NY Symptoms metal dust found in fuel system User requested that VW check the HPFP for abnormal wear.  User's fuel habits Unknown VW response (direct link) VW refused, cla... Read More »

#30 2009 Jetta TDI / gborgan / CA

June 18, 2010

This 2009 Jetta had 55,835 miles on it when it failed. User is from CA. Symptoms After 20 perfect months and 55k trouble-free miles, including two trips from San Diego to south Texas and several other long trips, suddenly there was a slight hesitation, some high pitched metalic tinkling n... Read More »

#31 2010 Jetta TDI / hocking / CA

June 18, 2010

This 2009 Jetta had less than 30,000 miles before failing to function. User is from Brea, CA. Symptoms Car failed with half a tank of fuel (Wed. June 2). Towed to dealer. VW response Told first that it was a broken fuel pressure sensor. They had car for the weekend. Monday we ... Read More »

#32 2009 Jetta TDI / chadjaeger / CA

June 18, 2010

This 2009 Jetta owner had 42,427 miles in about 18 months prior to failure. User is from LA/OC in Southern California. There is no forum link as this is a user who emailed us with the details of his TDI failure. Symptoms There were no symptoms prior to failure.  I had used a little o... Read More »

#33 2009 VW Jetta SportWagen TDI / rjgagliano / CA

July 2, 2010

This 2009 JSW had 9,800 miles before needing repair. User is from Southern California Symptoms My 09 TDI Jetta Sportswagen stopped today and had to be towed to the dealer. They just called and reported they found metal in the fuel. User's fuel habits Unknown VW respo... Read More »

#34 2010 VW Jetta SportWagen TDI / JohnofD / OR

July 2, 2010

This 2010 JSW had 6,400 miles before needing repair. User is from Oregon Symptoms MIL light won't go off, occasional Glo Plug, lack of acceleration at times. They replaced fuel pressure sensor. MIL comes back on soon. Next time fault code for Fuel Pressure Low. They noted fuel lev... Read More »

#4 2010 VW Jetta TDI / elester12 / VA

April 2, 2010

This 2010 Jetta had 6,000 miles before metal particles were found in the fuel filter. User is located in Fairfax, VA Symptoms LOTS of metal in my filter. Crappy engine power. User's fuel habits Unknown VW response Unknown Notes User also had a 2009 TDI that completely quit functioning.... Read More »

#5 2009 VW Jetta TDI - UNCONFIRMED / Plus 3 Golfer / AZ

April 2, 2010

This 2009 Jetta had 26,260 miles before metal particles were found in the fuel filter. There was no visible contamination at 20,000 miles. User is located in AZ. Symptoms When you look at the top of the filter with your naked eye, you can only see the very large particles. User's fuel habits UL... Read More »

#6 2009 VW Jetta SportWagen TDI / birkie / NY

April 2, 2010

This 2009 JSW had a build date of 02/09. It had 23,633 miles before needing repair. User is from Syracuse, NY. Symptoms Initially, it seemed like the "cold start scare" problem. Temp in the '30s, rainy, car started up normally but stalled abruptly after two seconds. Immediately afterward... Read More »

#7 2009 VW Jetta TDI / Nickofari / NH

April 2, 2010

This 2009 Jetta purchased in August 2009. User is from NH. Symptoms Car wouldn’t start. "small metal particles" found in the fuel system. Photos found here User's fuel habits Standard ULSD. No fuel additives. VW response VW is maintaining its position that my 2009 Jetta T... Read More »

#8 2010 VW Jetta TDI - UNCONFIRMED / Starbucker / OR

April 2, 2010

This 2010 Jetta has a build date of 7/2009. It had 3,500 miles before metal particles were found in the fuel system. User is from Portland, Oregon Symptoms Metal flakes in fuel system User's fuel habits Standard ULSD. PS fuel additive. VW response Unknown Repair estimate Unknown  ... Read More »

#9 2009 VW Jetta TDI / tonydec / NC

April 2, 2010

This 2009 Jetta had a build date 3/09, it was purchased 4/20/09. It had 9,906 before needing repair. User is from NC. Symptoms Car stopped running after a couple of hard starts on trip to NJ User's fuel habits Standard ULSD. No fuel additives. VW response Dealership in Freehold NJ immediat... Read More »